Propertyware TalkDesk Phone Issue 10/20/2025

Incident Report for Propertyware

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:28 CDT

Investigating

We are currently experiencing issues with our phone system and are working to have this service restored as soon as possible.
We apologize for the inconvenience.
Posted Oct 20, 2025 - 12:48 CDT
This incident affected: Phone support.